Firefox: invalid or unsupported form of compression

Jul 7, 2009 • alan


Occasionally, I have been seeing the following error in Firefox (v3.0.11).

The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression.

It occurs frequently when I am using a SOCKS proxy. One web site which happens to exhibit the problem more than others is Bruce Schneier’s blog.

The work-around that seems to work for me is to do a “Tools / Clear Private Data…” and select Cache, Cookies and Offline Website Data.

There’s a lively discussion on the Mozilla support forum, but no one seems to know what the source of the problem is.